Keep getting just "partially succeeded"

Sep 17, 2009 at 9:56 AM
Edited Sep 17, 2009 at 10:04 AM

I got two different failures from the Buddy Build Step: "Checking in the shelved changes"

Here is the first one:
Task "Exec"
  Command:
  "C:\Program Files (x86)\Microsoft Visual Studio 9.0\Common7\IDE\PrivateAssemblies\..\tf.exe" checkin /author:"domainabc\userabc"  /saved /recursive /noprompt
  TF10139: The following check-in policies have not been satisfied:
    The Code Analysis Policy requires files to be checked in through Visual Studio with an open solution.

How could I fix this?

 

If I turn off the "Code Andlysis" Check-in Policy as a workaround to get rid of the above issue, here is the second failure from the same build step:
Task "Exec"
  Command:
  "C:\Program Files (x86)\Microsoft Visual Studio 9.0\Common7\IDE\PrivateAssemblies\..\tf.exe" checkin /author:"domainabc\userabc"  /saved /recursive /noprompt
  Private\userxyz:
  Checking in edit: x.txt
  Checking in add: y.txt
  Updating 1 work item(s)
  failed to resolve work item: 355393
  Failed to update the following work item:
  ID 355393. Reason: TF26201: This work item has unsupported fields, or user does not have permissions.

  Changeset #256214 checked in.

What's the problem here?

Sep 18, 2009 at 8:49 AM

The second preblem is resolved, but I still don't know how to get rid of the first one. Any help is appreciated.

Coordinator
Sep 18, 2009 at 3:33 PM

You can override the policy violation upon check-in by setting the following from the "Buddy Build -> Settings" dialog:

1) Go to the "Miscellaneous" node.

2) Under the "Check-in Policy Settings" section, change the value of the "Override Check-in Policy Violations" setting to true.

This will cause all shelvesets created by the tool to contain the policy override comment and upon checkin in on the build agent, the policy violations will be overriden and your checkin should go through.

Please let me know if you still have issues after trying this.